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Use InDesign’s Preflight 

command to save money, save 

time, and save you from the 

hassle of botched print jobs.

Be a Production Hero without Breaking a Sweat
By KATHY SANDLER
It used to be that designers relied on production folks to pre-
pare files for the print shop. Now that everyone can create 
print-ready files in InDesign, bean counter bosses want to con-
sign all production experts to the trash heap. However, success-
ful file production still requires special skills, including a deep 
knowledge of color, prepress, and printing. But even if you’re 
lacking that wisdom, you can still save money, time, and trouble 

by taking advantage of the preflighting tools built into InDesign CS and CS2. I’ll show you 
how to use them to spot common and not-so-common trouble spots. 

Start with a Summary
Preflighting, according to Chuck 
Weger who coined the term almost 
two decades ago, is the pre-output 
analysis process. You preflight files 
to make sure that WYWIWRG 
(what you want is what readers get).

The easiest way to preflight in 
InDesign without investing in 
another application is to choose 
File>Preflight. The Preflight feature 
checks your file and reports prob-
lems with fonts, links and images, 
colors and inks, print settings, and 
external plug-ins. It also alerts you 
when there’s transparency in the 
file. The errors (or warnings) show 
up as a big yellow caution symbol 

(Figure 1). Here’s a rundown of each of the panels in the Preflight dialog box.
Check Hidden Layers. If you see Show Data for Hidden Layers in the Preflight 
Summary pane, the visibility of one or more layers is off. Since those layers 
might be turned on later, check this box so InDesign preflights them, too.
Fonts. Preflight’s Summary shows you the number of fonts used and whether 
they are missing, embedded, incomplete, or protected, any of which can cause 

■

■

FIGURE 1: Don’t bypass this 
Summary screen—read it!

InDepth: Preflighting



Missing Fonts
Even before you choose 
Preflight, InDesign offers 
some clues about how 
your fonts will (or won’t) 
be handled. When you 
open a document that 
includes a font not 
currently loaded on your 
system, the program 
alerts you (Figure 2). If 
you use the Find Font 
feature, remember that 
this can change fonts 
on your document and 
master pages, but it will 
not change the defini-
tions of paragraph and 
character styles. If you 
go ahead and open the 
document without chang-
ing the fonts, you’ll see 
the dreaded pink, as long 
as Substituted Fonts is 
enabled in the Preferences 
dialog box (Figure 3). If 
you place the cursor in 
the text, you’ll see the 
font name surrounded by 
square brackets  
(Figure 4).

FIGURE 2: You’d never say “OK” without at least pausing first, right?

FIGURE 3: Don’t ignore the pink. Don’t uncheck this preference. And don’t change to 
Preview Mode just to continue working when you’re missing fonts or you’ll be sorry!

FIGURE 4: Brackets around the font in the palette: a telltale sign you’re 
missing a font.
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font substitution on output (which 
means bitmapped text or worse—the 
dreaded Courier). 

There’s a lot of information within the 
Fonts section of the Summary screen. 
Number displays at a glance if you’ve 
got the right number of fonts. If you see 
you’re Missing a font, open it or change 
to another font that’s open. 

And when a font shows up as 
Incomplete, you’re missing screen or printer fonts. You’ll have to find the 
original disks or change to a different font. I recommend checking all your 
fonts with a utility such as FontDoctor ($69.99, www.morrisonsoftdesign.com) 
or FontAgent Pro (see review on page 55) before you load them so you don’t 
run into this problem. Before you bellyache about shelling out for yet another 
product, note that a full version of FontDoctor comes with Extensis Suitcase, 
so you might already have this utility.

Also in the Fonts section, Protected indicates that you can’t embed a font 
in a PDF because a font foundry has protected the font. If you have a PDF 
workflow, the only remedy is to substitute another font that isn’t protected.
Links and Images. The Summary screen shows the total number of linked 
images, whether any have been modified (which could result in the wrong 
version of the image), missing (which can cause a pixilated image to appear), 
embedded (which could bloat your InDesign file and make it harder to update 
the image later), or RGB (which could cause color shifts). Note that InDesign 
marks RGB images with a “warning” icon, but using RGB images is completely 
reasonable if you’re in a color-managed workflow (for more information on 
color management, see “Get Better Color” on page 6).
Colors and Inks. You can see the number of process and spot colors and 
whether color management is on or off. For most magazine editorial work, 
you don’t want spot colors. For promotion and ad work, compare the number 
of colors to the number you expect to pay the printer for. If you use a color-
managed workflow, you should see the message “CMS is on.”

The Summary screen also alerts you to duplicate spot colors (Figure 6). 
You can alias one to the other using Ink Manager in the fly-out menu of the 
Swatches palette or Output pane of the Print dialog box. However, it is better 
to change objects to one of the two colors (and delete the other) or your 
Swatches palette still shows both.

Don’t be fooled by differing results in the Preflight Summary, the 
Separations Preview palette, and the Output pane of the Print dialog box. Only 
the Preflight Summary shows the correct color information. The other two 
show all four process colors and all spot colors defined in your file, even when 

■

■
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FIGURE 5: Instead of pressing 
Fix Links Automatically, I suggest 
you click Don’t Fix. That way you 
can fix each link one at a time 
in the Links palette. This lets 
you watch the new or revised 
image come in and make sure 
you’re not harming the design 
or copyfit.

www.morrisonsoftdesign.com


they’re not used. Say you’re 
working in a file in which 
someone has defined every 
color under the sun, and 
you want to see whether 
they’re spot colors. Pick 
Select All Unused in 
the fly-out menu of the 
Swatches palette, then click 
on the trash can to delete 
them. (Do save a version 
first so you can bring those 
colors into other files later 
if necessary.) The Swatches 
palette will display a 
shorter list so you can 

easily scroll through and look for the telltale circles that denote a spot color. 
External Plug-ins. If you’re missing a third-party plug-in that someone used 
to create a file, InDesign may tell you when you open the file (Figure 7), but it 
may not. For example, I got a message when opening a file that someone had 
created with the Extensis Font Reserve plug-in for InDesign. But I didn’t get a 
message when I opened a file with Triple Triangle’s Mechanical Cubed plug-in 

missing. Strangely, other plug-ins 
don’t show up with an error message 
or in preflight, such as Sansui 
Software’s Fraction ’N’ Prices. If you 
get an error message about a missing 
plug-in, find out what the plug-in 
does and whether you need it. If the 
plug-in is unnecessary (for example, 
you don’t need Font Reserve to work 
on a file someone else created using 
that plug-in), you can usually safely 
check Delete Missing Plug-in Data 
from Document (but make a copy 

just in case you need an untouched original of the document). 
Troubleshooting Transparency. Non-Opaque Objects is a helpful item in 
Preflight’s Summary screen that’s easily missed. It tells you if you’ve used 
transparency, which is important because text and strokes can become 
rasterized if transparency is not used properly when output to older RIPs. 

■

■

FIGURE 6: The Summary screen 
reports if you have duplicate 
spot colors in the file. These 
are colors that are defined the 
same, but named differently, 
which will cost you extra money 
in wasted plates.

FIGURE 7: It may not really 
be a problem, but it’s good to 
know.
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Transparency can be a drop shadow, feather, transparency mode, or 
transparency opacity in InDesign; it can also be in a link if you used any 
of those effects in Photoshop or Illustrator, including an alpha channel 
or transparent background in Photoshop. If you see anything other than 
None after Non-Opaque Objects, go to the Pages palette and look for the 
checkerboard pattern. That shows you which spreads have transparency. 
Select Window>Output Preview>Flattener and check each of those pages for 
transparency problems. 

To determine whether transparency will be a problem at print time, open 
the Flattener Preview palette and pick Raster-fill Text and Strokes after 
Highlight from the Highlight popup menu. This displays in red the areas of 
concern (Figure 8). Red text will bitmap. If it’s part of a text block, then the 
red text could look heavier and bitmapped compared to the rest of the text. 
Sometimes it’s only part of a letter, which would look awful in print. To find 

FIGURE 8: If you pick Highlight: 
Raster-Fill Text and Strokes 
in the Transparency palette 
and then see red text in your 
document, the red text will 
bitmap at print time. In the 
example above, there’s a drop 
shadow on the image, but it’s 
not even touching this text.
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where transparency is used on the page, pick Highlight: Transparent Objects in 
the Flattener palette (Figure 9).

Luckily, there’s an easy fix for this—just make sure your text is on top of 
the transparent object. To do this, first check Auto Refresh Highlight in the 
Flattener palette so you can see whether your changes fix the problem. Then 
select the text frame that has red highlighting and pick Object > Arrange > 
Bring to front. 

Bringing the text to the front one time won’t solve the problem when the 
transparent object is on a layer above the text. In this case, you must move 
the text to the same layer as the transparent object and bring it to the front, 
or put it on a layer above the layer with the image. Once you do this, examine 
the file to make sure that the layering still appears as the designer intended. 
If text doesn’t wrap correctly, turn off Text Wrap Only Affects Text Beneath 
in InDesign > Preferences > Composition (Mac) or Edit > Preferences > 
Composition (PC). Then examine the file carefully to make sure this change 

FIGURE 9: When you change to 
Highlight: Transparent Objects, 
you can see why the text was 
bitmapping in Figure 8—the 
image with the drop shadow 
was rotated, and InDesign sees 
this red area as the bounding 
box for the transparency. The fix 
is to bring the text to front or 
put it on a layer above the layer 
with the image.
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doesn’t affect the design in 
the rest of the file. 

If bringing the text 
to the front would ruin 
the design, another 
alternative is to specify a 
custom flattener setting 
for this spread (by 
choosing Custom from 
the Spread Flattening 
submenu, in the Pages 
palette menu) and turn 
on the Convert All Text 
to Outlines option. Then 
it will all be uniformly 
thicker. However, this 
is not a recommended 
workaround because the 

text may not match text on other pages.
I almost always recommend that text be on a layer by itself on top of all 

other art objects. This will avoid transparency problems (and provide an easy 
way for you to lock all non-text objects before giving a file to editors to copyfit 
and edit). 

You may not be able to reposition strokes that the Flattener Preview shows 
are in front without changing the design. If the design has a shadow behind 
and an image with transparency on top, then the rasterization of the stroke 
on top of the shadow may not look offensive. Pull a high-end proof to see. If it 
looks OK, flag it for your printer so they know you signed off on it.
Number of Documents. You may wonder why InDesign reports the Number 
of Documents in the Summary screen of Preflight when it seems that you can 
preflight only one at a time. It has to do with books: If you combine documents 
together in a book palette, you can preflight multiple files at the same time 
(Figure 10). To preflight files from the book, pick Preflight Book from the flyout 
menu in the Book palette. The pagination options you see here refer to the 
Book pagination. The only drawback to preflighting multiple documents is 
that it doesn’t always show you which file has the problem, so you’ll have to 
hunt down this information manually.

File Intervention: Using the Preflight Panes
While the Preflight Summary screen gives you a lot of information, there’s more to find. 
First, after you run the Preflight command, click on each area to see more information. 

■

FIGURE 10: Make a Book (an 
easy thing to do) and then you 
can preflight multiple files (and 
Package, Print, and save the 
multiple files to PDF).
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Don’t check Show Problems Only because you’ll miss many problems that InDesign doesn’t 
classify as errors.

TrueType Fonts. InDesign won’t list the presence of TrueType fonts as errors, 
but a few printers say these fonts cause text reflow on older RIPs and different 
operating systems. If your printer frowns on TrueType, take the following 
steps: First find TrueType fonts by opening the Preflight window and click on 
Fonts on the left pane. Click on Find Font in the Preflight Fonts pane (or go to 
Type > Find Font) and click on the TrueType font. Then click on More Info to 
see where a font appears and how many characters are set in it. This tells you 
whether the font is only on the pasteboard, or if it’s one character, which might 
be a space. If you don’t need that font, you can change it. One tip regarding the 
Find Font dialog box: first pick the font you want to change at the top, then 
pick the font you want to replace it with at the bottom, then select Find First or 
Find, Change, or Change All. If you simply select Done, InDesign won’t make 
the change.

You might think you’re safe from font trouble if you use only OpenType, but 
that may not be true. There’s a flavor of OpenType called OpenType TrueType, 
and you have to click on Fonts in the Preflight pane (or in Find Font under 
the Type menu with More Info showing) to see whether it appears in the file. 
Also note that Apple created havoc for print professionals when it shipped Mac 
OS X with a new font technology called .dfonts. They are essentially TrueType 
fonts—but I don’t recommend you use them for prepress work.

I suggest you deactivate all fonts that come with your operating system, 
except those required for the OS. It’s not for the faint of heart, though, as you 
need Administrator privileges to your computer, and you can actually damage 
the machine if you delete either of the two required system fonts. For how-to 
details for deactivating system fonts on the Macintosh, download whitepapers 
from Apple (go to www.apple.com/pro and click on “Advanced Typography 
with Mac OSX”), Extensis (go to www.extensis.com and click on Creative 
Group Solutions, then “Best Practices for Managing Fonts in Mac OSX”), and 
Chuck Weger on creativepro.com (www.creativepro.com/story/feature/19593.
html and www.creativepro.com/story/feature/20000.html).
Links and Images Pane. There are more options in the Links and Images pane 
to check and fix your images. There are buttons labeled Relink (for Missing 
images), Update (for Modified images), and Repair All (for either). Relink 
is generally safe—it lets you find images if the folder or files were moved to 
another volume. Avoid Update. As I noted earlier, it’s usually better to go to the 
Links palette, click on the image, and pick Go To Link, then pick Update Link. 
Watch the screen to be sure the design didn’t change after the linked image 
updates.

■

■

TIP A BETTER SPREAD:
If you choose View>Fit Page 
in Window or any view other 
than Fit Spread in Window, 
the previous and next buttons 
in the lower-left corner of the 
document window (they look 
like little left and right triangles) 
act as previous page and next 
page buttons. However, if you 
choose Fit Spread in Window 
(Command-Option-zero), then 
these buttons move one spread 
backward or forward at a time.
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Effective Resolution is also reported in the Links and Images pane. You 
need to know each image’s effective resolution (resolution after scaling), which 
you can see by clicking on the Links and Images pane. This will show if you 
scaled up an image too much, causing pixelization. For example, a 300 DPI 
image that was to be a full-page image at 100% size will be only 150 DPI when 
scaled to 200% to accommodate a spread. 

File Type is the final item in the Links and Images pane. Make sure there 
are no GIF or PICT images, or any in the indexed color mode. If you expected 
images to be in CMYK mode, check here that none are in RGB mode. If the file 
came from InDesign 2, or has the wrong preference set, the imported text files 
may be linked. Unlink them.
Which Colors? Make sure to click on Colors and Inks and check it because 
while the Summary screen tells you the number of process and spot colors 
used, the Colors and Inks pane lists them so you can be sure the right ones are 
used.
Required Plug-ins. The only external plug-ins that cause printing problems 
are required plug-ins. If the Preflight command indicates an external plug-
in, cancel the process and hold down Command on Mac and pick About 
InDesign from the InDesign menu. On a PC, hold down Control and pick 
About InDesign from the Help menu. You’ll get a wealth of information about 
your file, including a list of required plug-ins. Most of the required plug-ins are 
from Adobe, but look for one in the External Plug-ins pane in Preflight, and 
you’ll know that no one can open the file without this plug-in.
Report. The text in the Preflight pane is quite small, so Olav Martin Kvern 
and David Blatner in Real World Adobe InDesign CS recommend you click on 
the button that says “Report” to generate a file you can open the file in a word 
processor. In that document, you can easily increase the font size. 

The Smart Thing to Do
The bean counters are wrong — there’s still a place for production experts. But if you use 
InDesign’s built-in preflighting tools, you’ll deliver a cleaner file that won’t cause problems 
at the printer. 

KATHY SANDLER is Associate Director of Premedia Technologies at Hearst Magazines. She is an Adobe Certified 
Expert in InDesign CS and a Past President of Women In Production. Send comments to her alter ego, Dr. 
Premedia, at drpremedia@earthlink.net.
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